Every few months I run into this because I forget that version 5 of the Jwt token library introduces a breaking change that makes it incompatible with OWIN/Katana v3.x self hosted apps. So, by having forgotten and updating my nuget packages, my app starts failling again.

Hopefully by writing a quick post I will remember this issue in the future. The fix is simple. Just downgrade your System.IdentityModel.Tokens.Jwt package back to version 4.0.4.x and it will start working again.

ASP.NET app fails after updating System.IdentityModel.Tokens.Jwt to version 5
Tagged on:         

Leave a Reply

barretblake
%d bloggers like this: